1. Guest, hurry up! Enter this giveaway to win an awesome cat-themed bag worth $64.99! Click here to enter today. Multiple daily entries!

Being Reviewed Smilies Are Slow To Load

Discussion in 'Site Help' started by Margret, Jun 11, 2017.

  1. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Smilies are extremely slow to load. The tendency is to think that your click didn't go through, for some unknown reason, and click again. This results in the editor assuming that you want the smiley menu off.

    Part of the problem has to do with the colors in the menu bar of the editor; I have trouble telling just from looking at the menu bar whether Boldface (for instance) is on or off, because the color change is very subtle. Since smilies are now being treated as an on/off option, like Boldface or Italics, rather than a pop-up the way they used to be, people are easily confused.
    ______________________

    Secondary problem: This thread is hard to find. I had to do a search on threads containing "site issues" in the title, which led me to "Issues with Site Conversion to New Platform," which is closed but contained a link here. It would be helpful if moderators included a link when reminding people to report issues. It would be even more helpful if there were a more permanent link to this thread at the top of the page, the way we had immediately after the switch. As things stand now, people aren't going to automatically report issues, they'll just talk about it in the "What's on Your Mind?" thread, where some moderator will have to notice and remind them to report.

    Margret
     
  2. AbbysMom

    AbbysMom At Abby's beck and call Staff Member Moderator

    53,580
    1,166
    May 18, 2005
    Massachusetts
    Hello! :wave3:

    We have a whole forum dedicated to issues with the site and I've moved your post to it.

    I'm going to tag @Anne for the smilie issue and mark it for Review.
     
  3. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Ah. Well, that just underscores the problem I had finding the correct place to post -- obviously I didn't.

    Margret
     
  4. Anne

    Anne Site Owner Staff Member Admin

    31,383
    1,460
    Oct 23, 2000
    On TCS
    Thanks for the feedback, Margret.
    I have a couple of follow up questions on the smilies:
    1. How long do they take to load? For me it's under a couple of seconds which may or may not be a long time depending on each user's experience.
    2. Which OS and browser are you using? Have you tried a different browser to see if loading times are different?

    As for the icons in the editor, I totally see what you're saying. It isn't always easy to figure out what's pressed and what's not, especially since there's a third state of "recently clicked". I will look into tweaking the shades a bit. As far as I know, it won't affect the smilies button because that one isn't a real toggle-off and toggle-on button like the font design ones.

    Finally, the help section is a forum and as such it's on the forums list. I will try and link to it from the footer and will see if it's possible to make it stand out a bit more.

    Thanks again for the feedback!
     
  5. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Windows 7 Professional (the 64-bit version of Windows 7) and Firefox Portable 64-bit, always the latest version, which is currently 53.0.3. I have Ghostery for Firefox but I've whitelisted TCS so that shouldn't be a problem.

    I'm extremely careful about what sites I visit, what I download, and how I install software, and I run frequent malware scans. The worst they've reported in over a year is junk files cluttering up my hard drive, which I let them take care of.

    No, I haven't tried a different browser, and I haven't timed it, but it's more than a couple of seconds. I can't time it now because I've been using the smilies recently so they'll be coming up immediately now.

    I'm not the only one experiencing problems, however. @tallyollyopia has reported here: The "What's on your mind?" Thread -2017 that about half the time she can't get them to come up at all; I think she's running into the double click problem. In fact, it was her post and our discussion of it that led to this bug report.

    Also, the visibility in the editor toolbar varies with room lighting. Right now, for me, it's much easier to see, which I put down to the amount of cloud cover and the angle of the sun (indirect lighting from south-facing windows with translucent white shades).

    I'll try Chrome and Torch in a few minutes and report on them. It will take me a while, because I'll have to sign in again.

    Margret
     
  6. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Torch: Less than a second. But the editor looks like this. No, I can't even upload the screen shot like this; I'll try it with Chrome.

    Margret
     
  7. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Apparently I've uninstalled Chrome. I'm now in Internet Explorer (which I hate). The smilies came up in just over a second. And here's the picture of the editor in Torch: And yes, I could have uploaded the picture; I was looking for the "Upload" button on the toolbar rather than down below (still getting used to the new, un-intuitive way of handling pictures).

    Could this be a problem with Firefox? Absolutely. Does that mean it shouldn't be fixed? Considering the popularity of Firefox I believe that would be a "No, it does not mean that."

    Margret

    TCS editor, Torch.png
     
  8. Margret

    Margret TCS Member Top Cat

    2,663
    1,097
    Jul 17, 2014
    Littleton, CO
    Just now, in Firefox: Over 3 seconds to begin coming up, over 10 seconds to completely load.

    Margret
     
  9. Anne

    Anne Site Owner Staff Member Admin

    31,383
    1,460
    Oct 23, 2000
    On TCS
    Thanks for the additional information. Firefox is not very popular anymore. Less than 4% of our visitors are using it. I'm not at all sure it's possible to fix the way Firefox handles these images without hurting loading times for more popular browsers but I'll definitely look into it. Thanks again!
     
  10. jcat

    jcat Mo(w)gli's can opener Staff Member Moderator

    60,828
    1,158
    Feb 13, 2003
    Mo(w)gli Monster's Lair
    The smilies are loading quite quickly in the latest version of Firefox (54.0).
     
  11. Anne

    Anne Site Owner Staff Member Admin

    31,383
    1,460
    Oct 23, 2000
    On TCS
    Quick update: I tweaked the editor toolbar buttons so that it's easier now to see that they are pressed. Instead of "grey over grey", they now have a more visible border when they're pressed.

    Unfortunately, this cannot affect the smilies button because that one works differently and doesn't have toggle on/off modes. I am still looking into changing that but it's going to be a whole lot more complicated (if at all possible).
     
    PushPurrCatPaws purraised this.
  12. jcat

    jcat Mo(w)gli's can opener Staff Member Moderator

    60,828
    1,158
    Feb 13, 2003
    Mo(w)gli Monster's Lair
    That's a big improvement!
     
  13. margd

    margd Chula and Paul's roommate Staff Member Advisor

    14,443
    3,812
    Feb 24, 2015
    Maryland USA
    I still use Firefox and the smilies loaded completely in about 3 seconds, maybe a bit less. I'm not sure why the difference but 3 seconds seems like a reasonable time to me.
     
    PushPurrCatPaws purraised this.
  14. PushPurrCatPaws

    PushPurrCatPaws TCS Member Top Cat

    2,472
    577
    May 22, 2015
    I also use FF at times, and the smilies load quickly for me on FF. Smilies are pretty small image files and should take hardly any time to load -- well, unless a site has thousands of them (sigh, I dream of sites like that - I love smilies! :biggrin: )
     

Share This Page